보안뉴스 창간 17주년을 축하합니다!!

Home > 전체기사

PHP 생태계를 위협하는 또 다른 공급망 공격의 가능성

입력 : 2022-10-05 14:00
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기
리포지터리들에서 나오는 끝없는 공격의 실마리...공급망 위험은 이미 현실

요약 : 보안 외신 시큐리티위크에 의하면 PHP 생태계의 기본 리포지터리인 패키지스트(Packagist)에서 고위험군의 취약점이 발견됐다고 한다. 이 취약점을 통해 악성 요소들을 리포지터리에 퍼트리는 게 가능하고, 이는 공급망 공격으로 발전할 수 있다고 보안 업체 소나소스(SonarSource)는 경고했다. 취약점은 CVE-2022-24828이며, 일종의 명령 주입 오류로 분류됐다. 패키지스트에서 패키지가 다운로드 되는 회수는 매달 20억 회 이상이라고 한다.

[이미지 = utoimage]


배경 : 소프트웨어 개발에 있어 리포지터리의 비중은 갈수록 커지고 있으며, 공격자들은 이 리포지터리를 노림으로써 자신들이 원하는 악성 코드를 효과적으로 유포할 수 있게 된다. 깃허브와 NPM, PyPI 등 주요 프로그래밍 생태계의 리포지터리에서 주기적으로 공격 소식이 나오고 있는 것도 이런 이유에서다.

말말말 : “패키지스트는 PHP 프로그래밍에 있어서 표준 리포지터리 그 자체입니다. PHP를 다루는 모든 개발자들이 패키지스트를 사용한다고 봐도 됩니다. 그러므로 이번 취약점은 상당한 PHP 프로젝트에 영향을 주었을 것이 분명해 보입니다.” -소나소스-
[국제부 문가용 기자(globoan@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기 네이버 블로그 보내기

  •  SNS에서도 보안뉴스를 받아보세요!! 
 하이젠 파워비즈 23년 11월 16일~2024년 11월 15일까지 아스트론시큐리티 파워비즈 2023년2월23일 시작 위즈디엔에스 2018 넷앤드 파워비즈 진행 2020년1월8일 시작~2021년 1월8일까지
설문조사
2023년 주요 보안 위협 가운데, 올해 말까지 가장 큰 피해를 끼칠 것으로 예상되는 위협은?
공급망 공격
다크웹 기반 랜섬웨어 조직
북한/중국/러시아 등 국가 지원 해킹그룹 활동
스마트폰을 노린 보안 위협
OT 타깃 공격
피싱 공격
기타(댓글로)