Home > 전체기사
인기 높은 워드프레스 플러그인에서 취약점 발견돼
  |  입력 : 2019-03-25 18:43
페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기
워드프레스 플러그인, 워드프레서 생태계에서 나타나는 문제의 주범
이번 취약점도 공격자들이 활발히 활용...패치 긴급히 필요함


[보안뉴스 문가용 기자] 인기 높은 워드프레스용 플러그인 개발사가 사용자들에게 조속한 업데이트를 권장하고 있다. 해당 플러그인에서 취약점이 발견됐는데, 이미 공격자들이 익스플로잇 하고 있다는 사실도 드러났기 때문이다. 업데이트가 불가한 상황이라면 플러그인을 비활성화 하라고 보안 전문가들은 권장하고 있다.

[이미지 = iclickart]


이 플러그인의 이름은 소셜 워페어(Social Warfare)로, 사용자들이 소셜 미디어 공유 버튼을 자신의 웹사이트에 추가할 수 있도록 해주는 기능을 가지고 있다. 약 7만 개 사이트에 설치되어 있으며, 80만 5천 번 이상 다운로드 된 기록을 가지고 있다. 최신의 3.5.2 버전은 스토어드 XSS 취약점을 가지고 있었는데, 공격자들이 이미 이를 활용하고 있었다.

“이 취약점을 악용할 경우 공격자들이 악성 자바스크립트 코드를 소셜 공유 링크에 주입할 수 있게 됩니다.” 워드프레스의 보안을 연구하는 워드펜스(Wordfence)의 미키 빈스트라(Mikey Veenstra)가 자사 블로그에 올린 내용이다. 그러면서 그는 소셜 워페어 사용자들에게 “3.5.3 버전으로 최대한 빨리 업데이트 하라”고 권고했다. “만약 3.5.3 버전 업이 불가능한 상황이라면, 소셜 워페어 플러그인을 비활성화시키는 게 안전합니다.”

이 취약점이 처음 발견되고 개념증명이 공개된 건 지난 주 화요일의 일이다. 그리고 얼마 지나지 않아 실제 공격이 발생했다. 그래서 워드프레스는 해당 플러그인을 잠시 내리고, 다운로드를 불가능하게 만들었다. 소셜 워페어 개발사는 “취약점에 대해 인지하고 있다”며 “최대한 빨리 업데이트를 개발할 것”이라고 발표했었다. 그리고 약속대로 패치가 나온 것이다.

하지만 워드펜스는 패치를 발표하며 공격에 대한 기술적 정보를 상세히 발표하지 않을 전망이라고 발표하기도 했다. 아직은 업데이트 된 버전이 완전히 정착하지 않았을 것이라고 보고 있고, 더 많은 사용자들이 패치를 적용할 때까지 기다리기 위해서다. 빈스트라는 “앞으로 추가 게시글을 통해 기술적인 내용을 공개할 것”이라고 약속했다.

그리고 약속됐던 개념증명 코드도 공개됐다. 소셜 워페어 플러그인에서 발견된 취약점의 핵심은 사용자들이 다른 사이트로부터 환경설정을 그대로 복사해올 수 있게 해주는 기능에 있었다. 설정을 그대로 가져오는 건데, 관리자의 권한도 필요 없었고, 심지어 로그인을 하지 않은 상태에서도 가능했다. 즉 아무나 사이트 설정 사항을 그대로 본 딸 수 있었던 것이다.

그러므로 “공격자는 조작된 설정 문서로 연결해주는 URL 값을 입력함으로써 공격 대상이 되는 웹사이트의 설정 내용을 덮어쓰기 할 수 있게 된다”고 워드펜스는 설명한다. 소셜 워페어가 설치된 워드프레스 사이트의 운영자를 이런 방식으로 여러 악성 사이트로 우회시키는 것이 가능하고, 쿠키를 통해 추적까지 할 수 있다고 워드펜스는 설명했다.

이 게시글에 따르면 “각종 성인물 사이트에서부터 기술 지원 사기용 사이트들까지, 사용자들을 우회시키기 위해 마련된 다양한 사이트들을 적발했다”고 한다.

워드프레스의 플러그인에서 오류가 나오고, 실제 공격에 이 오류가 활용되며, 이 때문에 플러그인의 유통이 잠시 중단된 것은 이번이 처음이 아니다. 보안 업체 임퍼바(Imperva)가 지난 1월에 발표한 바에 의하면 워드프레스에서 나타나는 취약점 문제의 98%가 플러그인 때문이라고 한다.

이번 취약점이 발견되기 직전에도 이지 WP SMTP(Easy WP SMTP)라는 플러그인에서 취약점이 발견되고, 실제 해커들의 공격에 활용된 바 있다. 빈스트라는 “워드프레스 플러그인에서 발견되는 취약점들은 많은 공격자들의 먹잇감이 된다”며 “워드프레스 기반 웹사이트 운영자들은 항상 플러그인 관련 소식에 귀를 기울여야 한다”고 덧붙였다.

3줄 요약
1. 워드프레스의 소셜 워페어 플러그인에서 스토어드 XSS 취약점 발견됨.
2. 이 취약점을 실제 공격자들이 활발하게 사용하고 있었음.
3. 워드프레스 환경에서는 플러그인 취약점 빈번해 주의 기울여야 함.

[국제부 문가용 기자(globoan@boannews.com)]

<저작권자: 보안뉴스(www.boannews.com) 무단전재-재배포금지>

  •  
  • 0
  • 페이스북 보내기 트위터 보내기 네이버 밴드 보내기 카카오 스토리 보내기


  •  SNS에서도 보안뉴스를 받아보세요!! 
모니터랩 파워비즈 6개월 2020년6월22~12월 22일 까지넷앤드 파워비즈 진행 2020년1월8일 시작~2021년 1월8일까지위즈디엔에스 2018파워비즈배너 시작 11월6일 20181105-20200131
설문조사
코로나19 사태로 인해 화상회의, 원격교육 등을 위한 협업 솔루션이 부상하고 있습니다. 현재 귀사에서 사용하고 있는 협업 솔루션은 무엇인가요?
마이크로소프트의 팀즈(Teams)
시스코시스템즈의 웹엑스(Webex)
구글의 행아웃 미트(Meet)
줌인터내셔녈의 줌(Zoom)
슬랙의 슬랙(Slack)
NHN의 두레이(Dooray)
이스트소프트의 팀업(TeamUP)
토스랩의 잔디(JANDI)
기타(댓글로)